Some users reporting issues with Redtail Hosted Email Services
Incident Report for Redtail Technology
Postmortem

For a brief moment, a hosted email services mail server experienced an issue that impacted users attempting to access their mailboxes. Our Engineers quickly resolved the issue to return access to those accounts residing on the impacted server.

Posted Mar 07, 2022 - 07:26 PST

Resolved
This incident has been resolved.
Posted Jan 24, 2022 - 13:19 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 24, 2022 - 12:59 PST
Investigating
Some customers are not able to login to webmail. We have identified the issue causing this and are working to resolve it.
Posted Jan 24, 2022 - 12:59 PST
This incident affected: Redtail Email.