Redtail Imaging Outage
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Apr 01, 2016 - 06:03 PDT
Identified
We are currently experiencing an issue with our Imaging and CRM document storage solutions. We sincerely apologize for any inconvenience or negative impact the issue has caused you and your business. We are working diligently to resolve the issue.
Posted Apr 01, 2016 - 01:52 PDT