Users reporting intermittent issues within Redtail CRM (Tailwag interface)
Incident Report for Redtail Technology
Resolved
Our magical team of extraordinary unicorn taming technology wizards have identified the root cause for the login issues being experienced by users of our Tailwag interface. The issue has now been obliterated into nothingness. We sincerely apologize for any inconvenience the issue may have caused.
Posted 6 months ago. Apr 19, 2017 - 12:08 PDT
Investigating
Some users are reporting intermittent issues navigating within or an inability to login to Redtail CRM's Tailwag interface. We are troubleshooting now to determine a root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted 6 months ago. Apr 19, 2017 - 09:51 PDT