Redtail CRM' Tailwag Interface Unable to Load
Incident Report for Redtail Technology
Resolved
We have corrected the issue. Access to has been restored.
Posted Jul 27, 2015 - 13:47 PDT
Investigating
Some users are currently experiencing "This webpage is not available" or other "Unable to load page" messages when attempting to access Redtail CRM's Tailwag interface. We are working to resolve the issue as quickly as possible.
Posted Jul 27, 2015 - 12:29 PDT