Partial Call Center VoIP Outage
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted 3 months ago. Oct 30, 2018 - 20:37 PDT
Identified
Vonage Engineers continue to work to restore voice services for impacted customers. We apologize for the delays you may have experienced phone our support department today.
Posted 3 months ago. Oct 30, 2018 - 18:46 PDT
Update
We are currently working with Vonage to resolve the issue impacting our support lines. We apologize for any delays in answering your calls.
Posted 3 months ago. Oct 30, 2018 - 12:06 PDT
Investigating
Our callers may experience longer than normal hold times when attempting to contact us by phone. This is due to partial outages within the Vonage VoIP service, which is impacting our call centers. Please remember that you can also email us at support@redtailtechnology.com or visit help.redtailtechnology.com for a plethora of knowledge sharing articles and videos. We do apologize for any inconvenience this may cause.
Posted 3 months ago. Oct 30, 2018 - 10:46 PDT