Partial Call Center VoIP Outage
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted 7 months ago. May 01, 2018 - 08:09 PDT
Identified
Our callers may experience longer than normal hold times when attempting to contact us by phone. This is due to partial outages within the Vonage VoIP service, which is impacting our call centers. Please remember that you can also email us at support@redtailtechnology.com or visit help.redtailtechnology.com for a cornucopia of knowledge. We do apologize for any inconvenience this may cause.
Posted 7 months ago. Apr 30, 2018 - 11:56 PDT