Users Reporting the inability to login to Redtail CRM (Tailwag Interface)
Incident Report for Redtail Technology
Resolved
Our magical team of awesome unicorn taming technology wizards have identified the root cause for the login issues being experienced by users of our Tailwag interface. The issue has now been pulverized into nothingness. We sincerely apologize for any inconvenience the issue may have caused.
Posted Sep 18, 2015 - 17:10 PDT
Investigating
Some users are reporting an inability to login to Redtail CRM (Tailwag version). We are troubleshooting now to determine what the issue may be. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted Sep 18, 2015 - 16:31 PDT