Users reporting the inability to login to Redtail CRM (Tailwag version)
Incident Report for Redtail Technology
Resolved
Issue Resolved! Let the revelry and merrymaking begin. Our Magnificent Network Maesters and their magical toolbox of knowledge and know how have saved the day once more. Turn to your left and give the person next you a high-five. If no one is there, give a high-five anyway. On a serious note, we do apologize for the issue and any impact it may have had on your business operations as Redtail plays a vital part of your success.
Posted Jun 29, 2016 - 13:08 PDT
Identified
Some users are reporting an inability to login to Redtail CRM (Tailwag interface). We are working diligently to resolve the issue. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted Jun 29, 2016 - 12:24 PDT