Redtail Imaging and CRM Document Storage Issue
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted May 11, 2016 - 10:34 PDT
Investigating
We are currently experiencing an intermittent issue with our Imaging and CRM document storage solutions. We sincerely apologize for any inconvenience or negative impact the issue has caused you and your business. We are currently working to resolve the issue.
Posted May 11, 2016 - 08:32 PDT