Call Center Internet Outage
Incident Report for Redtail Technology
Resolved
Internet service has been restored to all call centers at this time. Thank you for your patience.
Posted 9 months ago. Nov 13, 2017 - 16:28 PST
Identified
We are currently experiencing longer than normal hold times due to an internet issue impacting one of our call centers.
Posted 9 months ago. Nov 13, 2017 - 14:19 PST