Call Center Internet Outage
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted 5 months ago. Nov 17, 2017 - 15:11 PST
Investigating
Our callers may experience longer than normal hold times due to an internet issue impacting one of our call centers.
Posted 5 months ago. Nov 17, 2017 - 06:08 PST