Users reporting intermittent issues within Redtail CRM (Tailwag interface)
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted 10 months ago. Apr 24, 2017 - 20:56 PDT
Investigating
Some users are reporting intermittent issues navigating within or an inability to login to Redtail CRM's Tailwag interface. We have unleashed the issue-sniffing tech hounds to track down the root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted 10 months ago. Apr 24, 2017 - 11:07 PDT