Hosted Email Services Issue
Incident Report for Redtail Technology
Resolved
The issue impacting Redtail's hosted email services has been identified and resolved. We sincerely apologize for any inconvenience related to the issue.
Posted May 05, 2015 - 15:52 PDT
Investigating
Some users may be experiencing issues accessing their hosted email accounts, delays receiving inbound mail and momentary inability to send emails. We are currently working diligently to resolve the issue.
Posted May 05, 2015 - 10:52 PDT