Sacramento Power Outage
Incident Report for Redtail Technology
Resolved
As He-Man used to say on Saturday mornings "I have the power!" The Masters of the Universe have restored the power in Sacramento. We do apologize for any inconvenience this may have caused. Have a fantastic day!
Posted 5 months ago. Mar 06, 2017 - 13:38 PST
Identified
We are currently experiencing a power outage at our home office in Sacramento, CA. This may result in longer hold times for support calls. We do apologize for this issue and hope to have it resolved as soon as possible. Thank you for your understanding and patience.
Posted 5 months ago. Mar 06, 2017 - 12:48 PST