Users reporting issues logging into Redtail Imaging (Classic) (INC-5)
Incident Report for Redtail Technology
Resolved
This issue has been resolved.
Posted 3 months ago. Oct 19, 2017 - 15:53 PDT
Investigating
Some users are reporting an inability to login to Redtail Imaging (Classic). We have unleashed the issue-sniffing tech hounds to track down the root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted 3 months ago. Oct 19, 2017 - 12:42 PDT