Issue with Phone System Provider
Incident Report for Redtail Technology
Resolved
The issue impacting support calls with our phone service provider has been resolved. We do sincerely apologize for any inconvenience the issue may have caused you.
Posted about 2 months ago. Jan 04, 2017 - 11:33 PST
Investigating
We are currently experiencing some issues with our phone system provider. This may result in some support calls being inadvertently disconnected as well as longer than usual hold times as well. We do sincerely apologize for any inconvenience the issue may cause to your daily operations. We are currently working with the provider to resolve the issue.
Posted about 2 months ago. Jan 03, 2017 - 11:22 PST