Users reporting inability to login to Redtail CRM (Leapfrog interface)
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted 4 months ago. May 25, 2017 - 14:50 PDT
Investigating
Some users are reporting intermittent issues navigating within or an inability to login to Redtail CRM's Leapfrog interface. We have unleashed the issue-sniffing tech hounds to track down the root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted 4 months ago. May 25, 2017 - 11:46 PDT