Redtail Call Center 800 Number Outage
Incident Report for Redtail Technology
Resolved
Our Call Center 800 number is now back up. We apologize for any inconvenience the issue may have caused.
Posted 10 days ago. Jan 12, 2018 - 13:18 PST
Investigating
Investigating - Our Call Center is currently experiencing an issue with our 800 number. Please call our direct line at (916) 694-0200. We are working with our provider to resolve the issue.
Posted 10 days ago. Jan 12, 2018 - 13:03 PST