Call Center Internet Outage
Incident Report for Redtail Technology
Resolved
Our Call Center internet issue has subsided and hold times are back to normal. We apologize for any inconvenience the issue may have caused.
Posted 10 months ago. Jan 26, 2018 - 14:30 PST
Identified
Our callers may experience longer than normal hold times when attempting to contact us by phone. This is due to an internet issue impacting one of our call centers. Please remember that you can also email us at support@redtailtechnology.com or visit help.redtailtechnology.com for a cornucopia of knowledge. We do apologize for any inconvenience this may cause.
Posted 10 months ago. Jan 26, 2018 - 07:38 PST