Redtail Email Server Maintenance
Incident Report for Redtail Technology
Resolved
Maintenance has been completed.
Posted Jul 11, 2015 - 07:10 PDT
Identified
The scheduled Redtail Email Server Maintenance has extended past the designated window of 10:00pm to 4:00am PDT. We do apologize for this and any inconveniences this may cause. We anticipate the maintenance being completed shortly. We will update the our status once the maintenance has been completed.
Posted Jul 11, 2015 - 04:36 PDT